All systems operational

Completed
London Datacentre scheduled maintenance

Status
Resolved after about 2 hours
Started
December 05, 2022 at 5:00 PM
Completed
December 05, 2022 at 7:00 PM
Affects
Mojo Portal
Voice Services
  • Completed
    December 05, 2022 at 7:00 PM

    Maintenance has completed successfully

  • In progress
    December 05, 2022 at 5:00 PM

    Maintenance is now in progress

  • Planned
    December 05, 2022 at 5:00 PM

    We are performing server maintenance in London, some services may experience a brief disruption during this time.