All systems operational

Voice Services

Resolved
Partial outage
Started 5 months ago Lasted 18 minutes

Affected

Voice Services
Updates
  • Resolved
    Resolved

    3cx hosts are now operational and voice services have been restored.

    If you are still experiencing issues, please contact our help desk.

  • Investigating
    Investigating

    We are currently looking into an issue with one of our 3cx hosting platforms that is causing issues for a very small number of end users.