29th May 2019

Leased line connectivity Virgin Media multi-site leased line issues

Update 09:46 - we are still waiting for a further update from the splicing team. Apologies as they have clearly missed their ETA for the fix and we are pushing for further updates..


Update 08:15 - the engineers are continuing to work to restore service, the splicing team have given an ETA of 09:30 for service to be restored.


Update 07:30 - the engineers are now on-site and attending to the fault. We will continue to post updates as we receive them.


A number of leased lines have lost service overnight due to a Virgin Media major service outage. Virgin have been working on this through the night and have now identified a fibre cable break in the Camden area.

Our latest update is that engineers have been dispatched to the nearest hub site to resolve and we await further communications.

This affects approx 15 of our sites and all have leased lines served on Virgin Media fibre. The majority of our sites and services are completely unaffected.

We will continue to monitor and post updates as we get them.